HomeСпортRelated VideosMore From: 3ftDeep

How To: 4-TEC Jet Ski Troubleshooting (GTX 185 Sea-Doo Fuel Pump Repair)

248 ratings | 75959 views
While getting Chris' 2005 Sea-Doo GTX 185 ready for the first ride of the season, disaster strikes: it won't start. Unsure which one of the many modifications we made over the winter may be causing the problem, the 3ftDeep boys need to troubleshoot ...and fast! Get 3ftDeep stuff: http://3ftdeepsports.com/store Suggested Tools: CANDooPro URL: http://candoopro.com Fluke 115 Multimeter: http://www.amazon.com/gp/product/B000OCFFMW/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=B000OCFFMW&linkCode=as2&tag=3ftdeepsports-20&linkId=KY4ZJOWCUVHECHQQ Filmed in the great Pacific Northwest with a Canon T2i camera. Music: Strut Funk, by Dougie Wood.
Category: Спорт
Html code for embedding videos on your blog
Text Comments (109)
Shannon Williams (2 days ago)
Just spray fuel into the air intake if it starts then you know it's fuel much faster than all this crap
Shannon Williams (1 day ago)
+3ftDeep all you have to do is spray it into the air intake filter hose it will suck it directly into the piston and it will start if it's a fuel problem
3ftDeep (1 day ago)
How do you spray fuel into the air intake? i.e. what device do you use?
chueko976 (2 months ago)
Hi, I have a 2012 RXT-T. When I try to start it I have the same problem but at 5 attempt it start. Then when I use it run perfect, doesn't fail on low or high speed. But when I stop and try to start again half hour later is the same problem. What can I check to find the problem? Thanks in advance!
3ftDeep (2 months ago)
I'd start with changing the spark plugs, if you haven't done so already. Also, make sure they're all sparking. Also check the fuel injectors to make sure they're giving lots of fuel. You should also remove the air intake hose to the engine and see if that helps, as it could be a partially-clogged air hose. Good luck and let me know how it goes.
Avery Toal (2 months ago)
Please help !!!!! 2010 sea doo rxt215 new plugs with good spark, new battery, plenty of fuel from injectors, 2 beeps when key is installed. Turns over strong but will not start. even tried starting fluid, Only 54 hours also took ECM from another running ski but still don't start.
Avery Toal (2 months ago)
did a compression check and have 0 psi on all 3 cyl, pistons are going up and down .... i thought the tester was broken so i used it on a running ski and was getting 127psi. Any clue on that one !!
3ftDeep (2 months ago)
Are you sure you're getting spark from the plugs?
Avery Toal (2 months ago)
air box and hoses are taken apart and injectors spray very good.
3ftDeep (2 months ago)
Engines need 3 things to start: 1) air 2) fuel and 3) spark. You may have new spark plugs, but make sure they're sparking. Sounds like you've done that, so next step is make sure it's getting air (i.e. take off the air intake so it breathes straight from the air. Next check you're getting fuel. That's where I'd concentrate. Sounds like you may have a fuel pump issue or something in the fuel line. Make sure the fuel injectors are spraying. Good luck!
julien van zijl (3 months ago)
Hi 3ft deep i am having problems with my sea doo it is backfiring
Ingrid Davila (3 months ago)
+3ftDeep Hi 3ft deep, having problems with my jetski,, won't turn on only way it will turn on is if I add gas to the sparkplug noticed sparkplug has oil on tip, mind you I have not used it in 3 years.
julien van zijl (3 months ago)
3ftDeep 2005 rxt supercharged when i start it up it starts backfiring and make alot of noise
3ftDeep (3 months ago)
We'll need more information to help. What year, when does it backfire (doing what, under what conditions, etc.).
kostas karonis (3 months ago)
and you needed the laptop to tel you to check the sparks and fuel??? xaxaaa idiots
3ftDeep (3 months ago)
Watch again, friend. The laptop is used to control the fuel injector spray.
Dempsey Daniel (4 months ago)
I know this is a super old video but maybe you can help. I have a 2004 sea doo GTX supercharged and unfortunately it was flipped today and spent a good amount of time upside down. It was so filled with water it had to be towed to the ramp to get out. After draining the water out of the ski, I tried to crank it and it sputtered and shot water out the back. I did this several times until it finally cranked, but as soon as it did it was idling very rough and then kept going off. I wonder if I take the spark plugs out and let it get the water out by cranking it with them removed that will fix it? Not sure what to do. It was running strong this morning until a family member flipped it unfortunately. Sorry for the long post but maybe you can help me. I would really appreciate it!! If I have to take it in to the shop then I will. And do you think the jet ski is permanently ruined, the family member is convinced it is but I try to reassure him it's not. Thanks for any help you can offer!
3ftDeep (4 months ago)
It’s hard to say. It could be very minimal damage, it could be a bit more severe. I doubt it needs to be rebuilt though. Keep your fingers crossed.
Dempsey Daniel (4 months ago)
All right, so let I it sit overnight and went to crank it on the trailer. It finally cranked and seemed to be idling better. Put it in the water and slowly drove it around, still idled a little rough but started to sound better. Gave it some more gas and it then started getting up to speed (maybe 35-40) but every time I hit a wave it seemed to stall. Finally realized it wasn't going to work and was coming back to trailer and it started smoking really badly. Turned off the engine and drifted in and am going to take it to the shop tomorrow. Unfortunately I didn't have a way to the oil out before I tried it. Please be honest with me, how badly do you think it's messed up? The smoking is really worrying me!!! I'm worried it's going to have trashed the engine and be 1000s of dollars in repairs. Let me know what you think. Appreciate it
3ftDeep (4 months ago)
You need to make sure that there is no water in the engine. Check to see if the oil has turned milky, and if so change it at least two or three times. It needs to be done very quickly since if there is water in the engine permanent damage will result. Good luck!
Shirvon Cartwright (4 months ago)
Hi i just changed my fuel pump in my 2007 215 rxt supercharged i am getting 7500 to 8000 rpm on land but only 5500 rpm in the water can you help me out pls
3ftDeep (4 months ago)
It could be. You can check the fuel injector function if you had a Candoo Pro (see our earlier troubleshooting video). I suspect it's your supercharger, though. You should take the intake hose off and see if you can spin it. If it hasn't been rebuilt and it has ceramic washers, they could have failed. If it were my machine, I'd remove the supercharger and check it out. Good luck!
Shirvon Cartwright (4 months ago)
3ftDeep dont know just got the bike 2 months ago the old fuel pump filter was deterioated there was alot of dirt in the tank i did not clean the injectors think injectiors might be clogged from all the dirt that was in the tank
3ftDeep (4 months ago)
When was the last time your supercharger was rebuilt?
Jean-Christophe Landry (4 months ago)
Hi, thanks for this great video. On your movie, time 3:45, I can see you probably added an air filter. Can you please let me know more about the hardware (filter and duct and where you connect it to the airbox). take care,
3ftDeep (4 months ago)
The hose was 4 inches. It was a generic filter off eBay. The hose went into the supercharger inlet.
Salvador Cisneros (5 months ago)
Hi I have a 2000 sea'doo bombardier GTX and I took it out on the water but it won't go past 30 miles per hour what do you think that I could be thanks
3ftDeep (5 months ago)
Yikes, there could be lots of reasons for this. Start with the obvious and check your impeller and wear ring for an obstruction. Also, if the wear ring or impeller are badly damaged, that will greatly affect performance. Make sure you've got new spark plugs. Next, check for any damaged or leaking hoses or clamps. It could also be your fuel pump, but that's difficult to troubleshoot. Try those and let me know what you find. Good luck.
Shirvon Cartwright (6 months ago)
Thanks i clean the injectors and she is doing fine so far
Shirvon Cartwright (6 months ago)
Hi i have a 2007 seadoo rtx 215 supercharged it runs at full throtle for about a minute or so then dies but idles perfect once you let idle for about a minute it will take full throttle and do the same thing but if you ride 5500 rpm it runs fine without dying
3ftDeep (6 months ago)
Sounds like a fuel supply problem. Perhaps water in the line? I'd try some water in gas treatments, and then have the fuel injectors checked. Could also be the fuel pump. It may also sound crazy, but check the pump for any obstruction. Good luck.
Julio Rodriguez (7 months ago)
Hi I need help!! I’m trying figure out if my 05 gtx is 185 or 215. Looks just like the one in the video but my supercharged is black not red. Any idea?? Thank you
3ftDeep (7 months ago)
Some of the superchargers are black and some are red. If you have an internal intercooler, then you have a 215 horse power machine. Those intercoolers were only on the GTX supercharged Limited edition models.
Jim P. (7 months ago)
The reason we call them "Sea-Junk" here in the south. It's not if it's gonna break, but when..
Jim P. (7 months ago)
Watch some endurance racing. Long Beach to Catalina for an example. Not a Sea-Dog in the top-20..
3ftDeep (7 months ago)
Up here, the Sea-Doo riders spent a lot of time towing Yamahas to shore last year ... All kidding aside, they both have their issues. They need to be well-maintained and serviced regularly. Thanks for your comment.
Mark J (8 months ago)
Good video. I have a 2003 GTX 4 tec (non turbo). one day it ran normal, the next day after adding fresh 10 gallons of gas it did not even start. when the key is placed to the post I hear the buzz sound from inside the fuel tank but also I hear bubbling, and the sounds never stop. the dash will not light up, the SeaDoo will not turnover but there are the beeps. // battery is good, spark is good. Is that bubbling sound normal or do you suppose something on the fuel pump assembly is jacked or came loose?
Mark J (8 months ago)
replaced the fuel pump and both of the filters. the bubbling noise has stopped. Also went ahead and replaced the starter solenoid. Now the issue is that the 5A fuse blows every time I connect the key to the post. that fuse is for "EMS". what is EMS? any ideas what I should try next?
Mark J (8 months ago)
The fuel filters are clogged to high heaven! new filters and new pump are ordered and will arrive in a few days. I just discovered that the 5A fuse was blown (my diagram shows that its for the EMS start/stop/circuit) I replaced the fuse and it burned out immediately upon connecting the key, again and the next fuse burned out. could the fuse be burning out because at the moment the pump assembly is taken apart and not in its place?
3ftDeep (8 months ago)
It could be a bad fuel pump. I've never heard bubbling before. It could also be that something has come loose, as it sounds like the pump is working. The dash not lighting up is a bit of a concern, though. A fuel pump issue would not normally affect the LCD gauge. I would figure out the gauge issue first, though, as that repair may be cost prohibitive and it may be worth getting a new machine. It may be worth it to take it to a dealer for an estimate. Good luck!
Jeremy Albrecht (9 months ago)
@3feetdeep Hey so i just changed the fuel pump with a new one the jet ski starts and shuts off right away after like 5 seconds do you maybe know why ? Please i need help bad bin stuck like this for a while
Jeremy Albrecht (9 months ago)
3ftDeep Hey yes I did right before the fuel pump went out but I think I'll definitely check the key post I'll really appreciate it and will keep you updated
3ftDeep (9 months ago)
Did you have the problem before you installed the new fuel pump? If you did, I've heard of people having trouble with the key post. Do you lose electrical power, too?
Octavian Stamate (1 year ago)
Hi ! I search for an general tester for jetski ... kawasaki . Can somebody help me with a mark of one...good i hope
Chaos Zombie999 (1 year ago)
Nice job Chris
Jose Concepcion (1 year ago)
hi again, your my hero! can you do a MPEM harness AMP bloc pin connector video swap. My pins are green and broke off. I don't know which crimping tool to buy. Seadoo 529035939 is $207. I blew my valve to check it, thx. Vibration & NaCl break pin!! Tah Tah tannnnnnn
3ftDeep (1 year ago)
Sorry, but our videos are limited to repairs needed for our own machines. Hopefully you'll be able to find it somewhere else on the internet. Good luck.
Andor Koval (2 years ago)
Good video it show how we need to prep our watercraft when storing during the winter months then we won't run into these problems later.
Joe McIntyre (2 years ago)
In my jet ski the injectors are only shooting oil in to the engine. We can't figure out how to fix it. Please help!
3ftDeep (2 years ago)
Not sure what to say, unless someone put oil in the fuel tank on the 4Tec models there is no way oil can get into the fuel system are you sure it's oil and not old fuel from the machine sitting too long ? Drain and clean the fuel tank and refill with fresh fuel then try it again.
Fletch Lives Daily (2 years ago)
hey, just replaced the spark plugs and they are both running perfect...even without codes showing. Thnx for the help.
3ftDeep (2 years ago)
Great to hear! You're welcome.
bill kng (2 years ago)
Good vid. Quick question. Sportster 4tec started smoking on the water. Now won't start. It cranks, will start up for literally one second and that's it. Changed spark plugs and oil, no help. Tried the air supply disconnect like video, no help.. Any idea what usually causes engine to smoke or what my problem could be? Any help appreciated👍
Berry Guam (9 months ago)
@bill kng, i have the same seadoo sportster 4tec, white smoking on the water, but it runs did you slove your probelm yet? i am located in NY brooklyn.
bill kng (2 years ago)
+3ftDeep will give a try... Thanx brother! 👍
3ftDeep (2 years ago)
We haven't made any videos on that yet, but it's very easy. You just need to buy a gauge like that found at the following link, and follow the instructions. All you need to know with the PWC is how to run it in "drown mode", but that will be in your PWC's user manual. http://www.canadiantire.ca/en/pdp/equus-compression-tester-kit-0251016p.html#srp
bill kng (2 years ago)
+3ftDeep pretty new to this... All the work I've done I watch videos before to learn how.. You have any videos on doing that? Or any way to quickly explain? Thanx for any help !
3ftDeep (2 years ago)
Could be a bad piston/ring. Have you checked the compression of each cylinder?
Fletch Lives Daily (2 years ago)
will do. I let u know, thnx
Fletch Lives Daily (2 years ago)
I think both skis need rectifiers probly. the other ski also didn't get up to speed on the same day.
Okie bbq (5 months ago)
The rectifier wont keep you from getting up to speed. It only charges your battery. I had moisture build up at the bottom of my plugs once. Dried the plug holes out. Fixed my problem.
3ftDeep (2 years ago)
Double check to make sure you hooked up your sensor properly. It's strange that the problem started after you hooked up the new sensor, and I know of someone who had a similar problem after hooking up the oil pressure sensor the wrong way. Other than that, this is a tough one to diagnose over the internet. Check the air intake, too by disconnecting it from the engine to allow it to suck directly from the air. Good luck!
Fletch Lives Daily (2 years ago)
no sc..
3ftDeep (2 years ago)
Maybe. Do you have a supercharger?
Fletch Lives Daily (2 years ago)
hey. I'm getting steady revs over 5000. I think it the rectifier from what I read earlier. the battery sent a low code. I charge the batteries after use. sometimes the batteries show low when riding and restarting.....
Fletch Lives Daily (2 years ago)
Nice vid. I have a 07 4tec. Changed the ool sensor recently and there is no code or limp mode anymore. But now when I have it full throttle it only goes about 37. It would get up to 55. it will stay at 37 then Mabey go to 45 off and on while at full throttle. think it is fuel ijectors.
3ftDeep (2 years ago)
What sort of revs do you get?
Ray Blackburn (2 years ago)
Sorry Re above/below post 2005 GTX
Ray Blackburn (2 years ago)
Great how to! Any chance you could go into detail on how to R&R the common fuel rail, I think I have a plugged #2 fuel injector and want to clean it. Any help greatly appreciated. I will never let them sit too long with old gas ever again!!
3ftDeep (1 year ago)
We hooked it up to the Candoo Pro. It has a setting that allows you to spray the injectors.
Mark S. (1 year ago)
3ftDeep Perfect, I had the exact same question as the guy above, and was wondering how you sprayed the injectors like that. i think I may have a plugged one too.
3ftDeep (2 years ago)
We use a Candoo Pro to fire each injector individually out of the engine, so we can see how they're spraying. If you find one that's not spraying properly, you should try flushing some fuel injector cleaner through it, and try to keep the solution in the injector for a few days. If that doesn't work, you'll probably need to shell out $150 for a new one. Not sure if anyone else out there has a better solution ...
Eric Ostrowski (2 years ago)
I have a seadoo rxp 215 and out of the water it idles between 1800 and 2200 and seems just a little rough. any ideas? Maybe fuel filter? I know last time i was out it was only running about 8000rpms when usually 8120 hoping just crappy gas.
3ftDeep (2 years ago)
First thing to always do is check the spark plugs. Make sure they're fresh (changed every year), and clear of corrosion, etc. Make sure they're screwed in properly! Could be your filter, but could also be a fuel injector. Check all air inlets first, before checking fuel system, though. Take off tube to air intake to rule out nothing is plugging up the system. It could also be your driveline, though (pump, carbon ring, etc.). But I'd try those first. It's hard to diagnose these things over the internet. Good luck!
Nick Grucza (2 years ago)
Hey.. can't find any information online for my jetski and was hoping you could help me out. 2003 Seadoo GTX 4tec (non SC). Just bought it and was going through it before I took it out and noticed a cyl 3 misfire. Did tune up on it, siphoned old gas out, put 5 gals new gas, new plugs, checked wiring to ECM as well as the other module (forgot the name) and all is good. starts up fine now and idles good, but when giving gas from idle it dies. Haven't run it more than 15 secs without water and am scared to run with water in case it dies while water is on. Any knowledge on this condition? Thank you in advance. Any advice helps! Nick
3ftDeep (2 years ago)
Good to hear. Good luck!
Nick Grucza (2 years ago)
+3ftDeep started it up this morning, seems to be a lot better! I am assuming it was bad gas. Is it normal to have a slight hesitation during initial start up when you blurp the throttle? Seems to rev up "okay" now. Still not to my liking, but a million times better. I will check the intake tube. I actually have the ski apart right now and I have a buddy with an injector cleaner. I will see if he can give them a good cleaning.
3ftDeep (2 years ago)
That was my old ski (except I had the supercharger). There are lots of possible problems, but I would check the compression in the cylinders next. I'd then check the fuel injectors to make sure they're not gummed up, and that fuel is reaching the engine. Then I'd pull off the air intake hose off and make sure nothing was stuck in there blocking the air flow (like a plastic bag, which has been seen before, but not by me). A good way to check that the spark plugs are firing is to get a Candoo Pro. The way to check it in water is to launch the ski and tie it securely to the dock while running it in "neutral". Good luck!
Aaron Hinojos (2 years ago)
Wow ! That's why I stick to a 2 stroke , iv never had any of these issues, this is why the factory's went to 4 stroke, It's Costs 5x more to maintain then 2 stroke, you have 50% less to worry about , It'll be fun they said just put gas in no mixing it'll be fun '! Ohhh but don't forget you gotta change your oil and oil filter every some many hours ohhh and almost forgot about timing , valves , fuel pump , fuel rail , fuel injectors, Oh and you'll need a laptop and a $500 software to tell you why it won't run , And it'll cost you 3 grand to rebuild that top end WHEN not IF WHEN it blows up, I just don't understand the point in all this to ride a jet ski , I have 2 cylinders and 1 carb , I put oil in my gas and ride all day !, store it away take it back it mix gas and ride, ! If I wanted to work on all this 4 Tec stuff I would just go to my VEHICLE !,
KevinLab010 (2 years ago)
Excellent video!
antzw (2 years ago)
mate you made good work of that
Fahd Yassine (2 years ago)
what is that OBD machine you used to test and software as well please? . thanks
3ftDeep (2 years ago)
It's hard to say what they are without seeing them, but common the switches are often installed for a bilge pump, or for a battery cut-off switch. As for why they don't start, try first replacing the spark plugs, then make sure they're getting fuel (carbeurator/injectors, fuel pump, etc.). You can tell if the fuel pump is working, as when you put the key on you'll hear it buzz. Good luck!
Fahd Yassine (2 years ago)
+3ftDeep thank you so much for the quick response. I just bought a pair of 2000 millenium edition RX and they crank with a jump start from my car but wont start. I got them in a charity auction and they have toggle switches under the front storage box and another on the right side..do you have any idea why would anyone install such things or why they wouldn't start ?
3ftDeep (2 years ago)
We used an IBM laptop with a CanDoo Pro that comes with its own software. A link to the hardware is in the video description above.
Wonder Jet (2 years ago)
Take it to the shop.. I can tell buy the sound of your ratchet your cheap !! :))
Ingrid Davila (3 months ago)
+SeaDooEric Hi sea doo
SeaDooEric (2 years ago)
*you're.......idiot
Ali Musur (2 years ago)
was there an obd code before it wasnt running?
3ftDeep (2 years ago)
No, surprisingly. Lots of codes for tons of potential problems, but none for this.
Ali Musur (2 years ago)
how did you know that there was a faulty rubber seal??
David W (2 years ago)
Thanks, I took out pump on my other ski and saw that the orange washer went first. Now they are both running like champs. Fuel filters were completely deteriorated. Best 20 bucks ever spent on skis!
Jeffrey Eilman (2 years ago)
Hi David.  I just replaced the fuel pump on my fuel pump module.  The orange washer will go in first, and the metal washer will be second.  This is per the instructions that came with the fuel pump.
3ftDeep (2 years ago)
I'm not sure. I'll see if Chris knows, but if I were you I'd call the service department at my dealership and ask them. They'll probably know that level of detail. Good luck.
David W (2 years ago)
+3ftDeep I have been trying to change inner and outer filter in 2005 RXT 4 tec. I took fuel pump assembly apart and 2 washers came out from bottom that I am not sure what order they should be reinstalled. There was a rubber orange washer and a metal one. If you can help with that let me know.
Ali Musur (2 years ago)
+3ftDeep thank you for the inputs sir, ours ran only 18hrs but didnt run for more than a year, will check for the wirings, hopefull i could trace the culprit. On your opinion, can i directly run the pump through the battery just to check if its still good?
Javierproaso 842 (3 years ago)
excelente diagnóstico.
Tony Rollin (3 years ago)
Hi I need some help when I try to start my seadoo lrv 2001 it seems like the starter jams the other day I took it out started it up before putting it in the water but couldn't get it started in the water pulled it out of the water still wouldn't start tried so long the battery died had to change the battery now it's th next day and now the starter wont turn it seems to jam please help
3ftDeep (3 years ago)
+Tony Rollin Before you get into some complicated troubleshooting, have you put in some fresh spark plugs? It could be your starter, but there are other reasons why it isn't turning over. It's a tough one to troubleshoot over the internet, but I'll see if Chris has some simple ideas to try before pulling your starter motor.
Alex Alpine (3 years ago)
wow!! best video I've seen.
King Linebacker (3 years ago)
witch port on a 750s s does the fuel line go to
3ftDeep (3 years ago)
+Carolyn Brazeau Sorry, we're Sea-Doo guys. That sounds like a Polaris.
RicWorks247 (3 years ago)
excellent video
Aldo Allende Oliva (3 years ago)
i was wonder me if u can help me, my jet ski has a problem with the rpm, it doesn't reach more than 6000rpm and it has to go up to 7000 or more, now it only can go 50 kpm and before the issue 70kph the jet ski only has 4 hour, i took it to the dealer and they say that a have to replace the pump because the pump suck something but it is not cover on the warranty. my question is: what is the deal between pump and rpm, are they saying the true, why it is reducing the speed and power. this one is a yamaha v1 2015
3ftDeep (2 years ago)
Sorry, I just noticed your comment. There are a few reasons why it doesn't reach maximum revs, but bad pump bearings are the most likely. I'm surprised they would have to replace the entire pump. The reason bad bearings (or damaged pump) could cause a decline in the RPMs, is because the drive shaft is supported at two ends: the engine, and at the pump. So, if the either support end is damaged, it can't spin at its maximum potential. I hope you got your problem solved. My apologies again for the delay, I don't know how I missed your comment.
RomeoSierra011 (3 years ago)
Nice.

Would you like to comment?

Join YouTube for a free account, or sign in if you are already a member.